VEXIQ Mimic does not run program

Hello, I am trying to use Robot Mesh Studio Mimic with the IQ system and with the C++ language. I built my mimic robot and when I try to run my program, the following shows:

Saved Time: 130 ms

lib_type: emscripten
Compiling: main.cpp
shared:ERROR: vexiq_smartdrive.cpp.o: No such file or directory (“vexiq_smartdrive.cpp.o” was expected to be an input file, based on the commandline arguments provided)

error: link failed

User build failed.

Compiling failed: Program has errors. See output for details. Time: 597 ms

Thank you.

Hello, Same issue here. I’m trying to build V5 C++ projects that worked yesterday.

1 Like

Really? Well, I thought I was missing the “vexiq_smartdrive.cpp.o” include file, but when I added it, it did not recognized it.

Hello @Uriel1795 and @jpalardy, we pushed an update yesterday that appears to have introduced this problem. I’ll let you know when we get a fix out for this, which shouldn’t be too much longer now.

1 Like

@Uriel1795 @jpalardy This should be fixed. Give it another try.

1 Like

Really? That was quicker than what I thought.

I still get the same error

Sorry about that, there was a similar one with the V5 system. Should be fixed for IQ now, too.

1 Like

Working now. Thank you!

BTW - I like the new help button.

Runs now! Thanks a lot!