All my Mimic parts have turned into shapes

All my Mimic parts have turned into shapes and my robots wont stay together.

Capture

The mimic textures have changed with an update made this weekend (https://forum.robotmesh.com/t/robot-mesh-mimic-3d-model-representations)

The robot should stay together and work exactly as before. Please share a URL to a robot that doesn’t stay together and we will fix ASAP.

These are just a few,
Most robots in my account do not work.
I have a class this afternoon but I assume all my students robots will be dead as well.
I am sure that they will let me know,

https://www.robotmesh.com/studio/5f54d4fdba53964ce07a6593
https://www.robotmesh.com/studio/5ee8bce61ba0112e80089a38
https://www.robotmesh.com/studio/5ed4fc18262ce21ca89f61af

Note as I am in Australia my classes are mid way through as we have a January to December School year, we are also in lockdown so currently all of my students are remote learning from home. These students have been working with Robot mesh Mimic for some time now and I hope that we will not have to start again.

Stephen

Thank you for the links.

I have now fixed the bug which resulted in the robots falling apart. There should be no need to start again or to re-construct your robots. The change made this weekend should only be a graphical change. Any change in behavior is a bug and we’ll fix it.

Sorry for the inconvenience. Hope this works ok for your lessons today!

Thanks the robots are holding together now, though the quad encoders seem to be performing differently but this may be an issue with my code. However, as I try to work through it I am getting another issue that when I try to run the the program I am getting timeouts when I press play. This occurs after about the third test, I tried on another computer and a different robot but it is the same.
timeout

Hi Stephen.

A while True: loop will run as fast as it can, just as you told it to. This is fine on a microcontroller where nothing else is running, but will make Chrome unhappy. Try adding a sys.sleep(0.001) to any forever loops you might have.

Cheers, Sam.

Thanks Sam,
I am still having the issue with a simple programs with no loops or decisions. (screenshot attached)
This happens when you click play and status is indicating compiling, it is taking around 45 plus seconds before the robot starts to run and I get the timeout error, however, the status is reporting that it compiled in 37ms.
This is affecting more than one computer. I have been using RobotMesh Mimic continually for the last 6 weeks with my current class but this problem has only started this week. Previously the compile period would be only a few seconds if that.
Note that I am using Chrome and that I tried Firefox after your post and it does seem much better.
However Firefox does not seem to run the programs reliably.
timeout2

Could you make that project public, including code, and provide a link to it?

Here is a project, you may have to run it three or four times before the problem occurs.

https://www.robotmesh.com/studio/5f588027bdebde75367dbc9d

Well further to this, I have been using it all afternoon and it seems to be working a lot better now. This is weird as it has been bad all week until today.

So Maybe its OK ??

1 Like